Home Banner image
Home

ProjectMIDI Developer Frequently Asked Questions

  1. Must I use C# for creating new assemblies?

    No. That's just my language of preference. Other supported .NET languages may work.

  2. Is .NET 2.0 or later required?

    Yes.

  3. Do I have to purchase Visual Studio 2005?

    No. The .NET Framework SDK includes command line compilers which can be used to compile your code. This is not as convenient or easy as using the Visual Studio IDE, but is is free. This is available from the MSDN site. Search on ".NET Framework SDK".

  4. Are MIDI System Exclusive messages supported?

    Yes. Both input and output Sys-Ex messages are now supported.